thesmartclub - the world's largest independent club for all things smart thesmartclub - the world's largest independent club for all things smart thesmartclub shop - the world's largest independent club for all things smart
+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2005
    Location
    Kildare, Ireland
    Posts
    128

    Question 451 Brabus - sudden loss of power at 4k revs

    Hi all,
    Long time member and back in a Smart again for the first time in a while. I bought a 451 a few days ago that's got some strange issues, so looking for advice.

    It pulls strongly in all gears when the turbo spools up, but as you continue up the rev range it flattens off after the initial surge. I assume this isn't normal. Also, in second gear it suddenly loses all thrust at 4k revs. It's quite abrupt and feels almost like a limiter or boost cut. Not sure if it only happens when cold as I haven't had much opportunity to drive it.

    No engine check light but just read the error codes and it is showing P0235 - Turbo/Super Charger Boost Sensor "A" Circuit.

    The first thing I noticed was the e-clip on the wastegate actuator arm was missing. I installed one, but it hasn't solved anything. The actuator is totally rusted beyond belief, so I've ordered a new one.

    So while I wait for the actuator to arrive, anyone have any idle speculation on the cause? Any point changing the MAP sensor?

  2. #2
    Join Date
    Jul 2005
    Location
    Chobham Surrey
    Posts
    543

    Default Re: 451 Brabus - sudden loss of power at 4k revs

    Take it to someone that knows smarts

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts