+ Reply to Thread
Page 4 of 4 FirstFirst 1 2 3 4
Results 31 to 35 of 35
  1. #31
    Join Date
    May 2018
    Location
    Woking, UK
    Posts
    86

    Default Have you ever had CAN bus issues?

    Latest update and it is not good news.

    I give up, I just canít get to the bottom of it. Iíve tried everything I can think of. I got a replacement speedo and cloned my one over to it. Still cuts out and I still get the one line, CANbus error for a few tries at starting before it goes into neutral and starts. The log is full of CANbus errors from the other modules and if I try and interrogate the ESP I am told there is a communication problem.



    I got myself a replacement ABS pump and swapped the electrical connections over to it and I get the same error. Iíve checked supply and earth to the ESP as well as the CANbus wiring throughout the whole car. The ABS works okay if I brake on a gravel road and it holds the car in the brakes for a hill start so it cannot be the problem. This latest test proves that.

    So thatís it really. There *are* no wiring problems. The ABS, yaw, speedo and ECU have all been swapped out, the engine still cuts out and the single line on the speedo is saying itís a CANbus fault and so is the MB Star system. I think itís now terminal, I have to give up at this point. Spent way too much time and money on what is essentially a basket case. Thereís no happy ending to this story. Seems like CANbus errors potentially mean the end of the car.🙁
    Last edited by Smartysmartface; 13th October 2018 at 15:58.

  2. #32
    Join Date
    May 2018
    Location
    Woking, UK
    Posts
    86

    Default Re: Have you ever had CAN bus issues?

    Hopefully the final update on this subject. After giving up myself I caved and took the car to SmartCarSpecialist in Guildford. £69 later and the diagnosis was it's the SAM. So what to do? New SAM for £750 is a fair price, but more than the car worth. Found a repair service on eBay, 5 year guaranteed repair for £200. So I went for that. Brilliant service. SAM was delivered to them on Monday and it arrived back fixed on Tuesday. How amazing is that. ELECTRONICS SERVICES, 22 Milton Road, Gillingham, Kent. ME7 5LN if anybody is interested. And no more cutting out! Off to the NEC in it on Sunday so fingers crossed.

    Hindsight is a wonderful thing and what I should have done is use a specialist earlier in the process. One major spanner in the works is my MB Star system which still can't interrogate the ESP controller. This resulted in a wild goose chase which I wouldn't want to repeat!

  3. #33
    Join Date
    May 2018
    Location
    Woking, UK
    Posts
    86

    Default Have you ever had CAN bus issues?

    Quote Originally Posted by Smartysmartface View Post
    Hopefully the final update on this subject. After giving up myself I caved and took the car to SmartCarSpecialist in Guildford. £69 later and the diagnosis was it's the SAM. So what to do? New SAM for £750 is a fair price, but more than the car worth. Found a repair service on eBay, 5 year guaranteed repair for £200. So I went for that. Brilliant service. SAM was delivered to them on Monday and it arrived back fixed on Tuesday. How amazing is that. ELECTRONICS SERVICES, 22 Milton Road, Gillingham, Kent. ME7 5LN if anybody is interested. And no more cutting out! Off to the NEC in it on Sunday so fingers crossed.

    Hindsight is a wonderful thing and what I should have done is use a specialist earlier in the process. One major spanner in the works is my MB Star system which still can't interrogate the ESP controller. This resulted in a wild goose chase which I wouldn't want to repeat!
    Still good news. Took the car to the NEC and back (210 mile round trip) and it didnít miss a beat. My £240 eBay is fully back in the road. 😊


    Sent from my iPhone using Tapatalk

  4. #34
    Join Date
    Mar 2016
    Location
    Wakefield
    Posts
    36

    Default Re: Have you ever had CAN bus issues?

    What did the specialist use to diagnose the fault?

  5. #35
    Join Date
    May 2018
    Location
    Woking, UK
    Posts
    86

    Default Have you ever had CAN bus issues?

    Quote Originally Posted by retroman View Post
    What did the specialist use to diagnose the fault?
    He used the same MB Star system but mainly, his 20 years of experience of working on Smart cars. Unfortunately you canít buy that, but you can rent it which is what I did. The Star system just showed loads of CANbus errors. The SAM was the only module left that I hadnít swapped out. But if anybody reads this thread and has a Smart that cuts out suddenly for no apparent reason and shows the single line on the dash (CANbus). If theyíve checked the usual suspects like CANbus wiring, loose connectors etc then it could be the SAM unit. Best advice would be to take to a specialist but donít pay £750+ for a new SAM, just get your own one fixed (~£200). I had taken my own SAM apart to look at it and there was nothing visible, so there was no clue that it might be faulty.


    Sent from my iPhone using Tapatalk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts