+ Reply to Thread
Results 1 to 4 of 4
  1. #1

    Default Electrical fault

    Hello, I have a Smart Roadster Coupe 2005. On occasion all the warning lights come on, engine will stutter, Rev-counter fails, power steering fails, hill start assist fails. The transmission mode and fuel gage disappears and is replaced with flashing bars. The car will not start. Turn off the ignition and leave for 5 to 10 minutes and it will restart and then run fine all systems restored. My Smart has a new SAM unit and new engine all work by Mercides Benz Truro
    Has any one out there experienced anything similar ?

  2. #2
    Join Date
    Jul 2005
    Location
    over here
    Posts
    13,867

    Default Re: Electrical fault

    Quote Originally Posted by Robert J Pickford View Post
    My Smart has a new SAM unit
    When ?

    And were the leak problems that undoubtedly caused the SAM replacement sorted too ?
    fq101.co.uk

  3. #3

    Default Re: Electrical fault

    New engine and SAM unit fitted September 2016 and yes SAM has been water proofed.

  4. #4
    Join Date
    Feb 2006
    Location
    Hampshire
    Posts
    1,113

    Default Re: Electrical fault

    What you describe is classic symptoms of power supply failure and the systems gradually shutting themselves off.

    Read this topic on the roadster forum for more advice:

    http://www.theroadster.net/trc/modul...topic_id=28686

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts